Jump to content
Impact Bumpers
Mobydick

Targa Top - Pin Rubbers - help!

Recommended Posts

It was only supposed to be a 2 min job -replace the two perished rubber covers on the rear pins of the Targa top!

After some time, I’ve got one on - but I can’t seem to get it fully home . 

I put dry lube on the pins and the hard rubber cover, but I just can’t seem to get it to  go to the last stage.

I can’t get it off either .Any ideas ?

113E7844-AC48-421C-AD4B-7BDF4192BBAC.jpeg

Share this post


Link to post
Share on other sites

Can you warm it up gently with a heat gun? Maybe that’ll soften it up a bit so that you can either push it fully on or slide it off.

 

Share this post


Link to post
Share on other sites

Thanks Rusty - I did consider that , but I’m a bit chicken to take a heat gun to the Targa too in case I cause other damage.

I thought of jetting it off, buying another one , and heating it up with a heat gun before I put it on. 

But I’m so close - it just needs to go a bit further. 

Share this post


Link to post
Share on other sites
3 minutes ago, Mobydick said:

Thanks Rusty - I did consider that , but I’m a bit chicken to take a heat gun to the Targa too in case I cause other damage.

I thought of jetting it off, buying another one , and heating it up with a heat gun before I put it on. 

But I’m so close - it just needs to go a bit further. 

It doesn’t need to be too hot I suspect.

Try a hairdryer.👍

Or hot water, just enough to soften it up a little.

Or squirt a load of washing up liquid around it and use some pliers wrapped in cloth to grip it and twist it at the same time. Don’t just try to push it straight.

Regards

Russ

 

Share this post


Link to post
Share on other sites

Thanks -will try your tips  tomorrow - hands are a bit sore now !

Share this post


Link to post
Share on other sites

Tried all of that on 3 roofs, nothing worked. Let us know how to do it!

 

 

Share this post


Link to post
Share on other sites

Your the man Rusty B !

i tried it with the pliers and a cloth (no heat) and it popped on. 

I just got the other one to do now!  I think I will try and ensure its better lubed. 

Do you know if the pins should be lubed externally when fitting onto the car?

Perhaps dry lube?

Share this post


Link to post
Share on other sites
16 minutes ago, Type911 said:

Tried all of that on 3 roofs, nothing worked. Let us know how to do it!

 

 

You should’ve come to me Matt😜😜

Share this post


Link to post
Share on other sites
17 minutes ago, Mobydick said:

Your the man Rusty B !

i tried it with the pliers and a cloth (no heat) and it popped on. 

I just got the other one to do now!  I think I will try and ensure its better lubed. 

Do you know if the pins should be lubed externally when fitting onto the car?

Perhaps dry lube?

Glad it helped!

I don’t think mine have any lube on. Maybe a smear of grease?

Washing up liquid is a fab lubricant and it washes off easily! 😁 And leaves stuff clean as well😂

regards

Russ

 

Share this post


Link to post
Share on other sites

I had this problem... and almost cried when trying to pull off these expensive pieces of plastic with pliers leaving them looking tatty. Finally got them on easily by putting in v hot water ( like setting a gumshield). Glad you got them on!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...