Jump to content

Recommended Posts

Hi, 

Pretty new here was hoping for some good advice. I recently bought a 3.2 Carrera (84) and absolutely love it. I have done a thorough look for rust and overall it seem to be really solid, except for one specific place, just over the battery, underneath it, there is no rust. 

What should i do to avoid it from spreading more? I was thinking of using a Dremel to remove the lose rust, use some rust removal and then prime it. Does that sound like a good approach?

20200811_105520_resized.jpg

 

Would be really thankful for advice/input. 

 

BR

H

Link to post
Share on other sites

Welcome

That is probably rusting from the other side of that section

Take the wheel off and have a prod

Link to post
Share on other sites

I fear your rust is coming in from outside where there is the front bumper mount bracket which tends to fill with muck and stay wet. It’s a wing off job to fix. However if that bit is rusty I’d be amazed if it wasn’t rusty elsewhere. Take the car to a specialist for an honest appraisal. May not be good news but better to know. As has been said here many times before, these cars do hide their rust well.

good luck.

Link to post
Share on other sites

Certainly not as bad as the image Simon posted, but the rust you see on the inside is most likely made it's way from the outside from behind the bumper mount.

I had similar in mine for years, I monitored and controlled it the best I could until the day came to look at it properly.  Unless you plan to take the wing off soon I'd remove the front wheel and deep clean everything making sure there is no dirt sitting on top of the bumper mount, clean the rust back, then treat and paint it and then smother it in Dinitrol or similar.  Then pretty much the same on the inside.  You'll need to remove the expansion tank and water res for better access.

That should hold the spread of the rust back until you need to take the wing off, remove the mount and repair the metal beneath.  You'll probably find other issues too at the same time.

Same happens on the other side but usually to a lesser extent.

Looking at your pictures you don't have the water res and expansion tank fitted.  

20200811_133811_resized.jpg

20200811_105520_resized.jpg

Edited by Nige
Link to post
Share on other sites
  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...